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Simple Network Management Protocol (SNMP) is typically used by network monitoring tools to poll the 

status of devices like routers or switches in an IP network. Using SNMP, network management systems 

can monitor performance, availability, and detect faults in the network that can impact business-critical IT 

processes. Network administrators need statistical data to validate network performance that can be 

achieved by independently polling data from the routers and switches by using MIBs and OIDs.  

Role of MIBs and OIDs in SNMP Diagnostics 

SNMP diagnostics utilize a Management Information Base (MIB), which is available in all SNMP-compliant 

devices. The information polled is available as raw data in the network device, i.e. an ‘object’ that resides 

within the MIB. Every object is uniquely identified with an object identifier (OID). Network devices have a 

database called ‘MIB table’ or ‘MIB Tree’ with these set of ‘objects’. An object stores valuable information 

like memory status, hardware status, etc. within the network device. OID is an identifier used to name 

and point to an object in the MIB hierarchy. 

SNMP-enabled network devices (e.g. routers, switches, etc.) maintain a database of system status, 

availability, and performance information as objects. These objects are identified by OIDs in the form of a 

piece of quantifiable data that gives you statistical information to maintain an effective network system. 

Difficulties in Collecting SNMP Diagnostics while Network Troubleshooting 

Each network device has its own MIB table with multiple OIDs. A large multi-vendor network may have 

thousands of OIDs to account for, and it’s difficult for network administrators to remember all those OIDs 

and MIBs while managing distributed networks. To retrieve custom MIB objects, administrators have to 

use MIB browsers that will help them find OIDs. It’s a time consuming process to go through each MIB 

tree for a specific device to find supported MIBs and OIDs, and pull raw data for each OID. Without 

knowing the MIB and OIDs, administrators can’t retrieve data or make changes to device configurations. 

In a large network, using commands for gathering statistical data for devices can be a problem if network 

administrators have to manually use OIDs and MIBs to read raw data from devices. 
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Typically, SNMP diagnostics are used in network troubleshooting. By identifying additional network 

statistical data, administrators can speed up the process of investigating repeated network failures. The 

process of manually collecting MIB and OID data is so difficult that network administrators can’t focus on 

network problems that are given higher priority. Third-party MIB browsers come in handy for network 

engineers while managing remote devices in the network. 

It’s important to have the right tools for effective network troubleshooting. The SolarWinds® Engineer’s 

Toolset provides you with the ability to quickly search and view MIB and OID data with the help of tools 

such as MIB Viewer, MIB Walk, and SNMP MIB Browser. The common issues that network administrators 

face while managing MIBs and OIDs are: 

 How to find the supported MIBs and OIDs for a particular device 

 How to find and retrieve frequently used MIBs 

 How to browse, query, and update MIB values remotely via SNMP MIB browser 

#1 How to Find the Supported MIBs and OIDs for a Specific Network Device 

Using MIB Walk 

The MIB Walk tool in Engineer’s Toolset walks the SNMP tree of a specific device and pulls the value of 

each OID in the supported MIBs. MIB Walk uses the SolarWinds MIB database to determine the common, 

readable, name for each OID and the MIB to which it belongs. SNMP communication must be enabled on 

the device to start this process.  

To walk the MIBs, you can use either the read-only or the read-write community string. SolarWinds MIB 

Walk produces a complete listing of all supported MIBs and OIDs and reports the current setting for each 

OID. In only a few minutes, you'll have a listing of all supported MIBs and OIDs. 

To walk the MIBs on a device: 

Look for MIB Walk in Engineer’s Toolset and launch the tool to open a new window.  

Step 1: Specify the hostname or IP address for the device. 

Step 2: Specify the SNMP community string. 
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Step 3: Select the SNMP tree to walk – Standard starts the SNMP walk from 1.3.6.1.2 and Private starts 

the SNMP walk from 1.3.6.1.4 

Step 4: Click Walk. 

 

Step 5: Copy, Export, or Print the result.  

After retrieving MIB values, MIB Walk allows you to transfer that information to other tools through 

exporting and copy and paste capabilities. You can either copy, export, or print discovered information. 
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 To Export: Click File > Export and then select the type of export 

 To Copy: Click Edit > Copy, and then specify whether you want to copy all to the clipboard or a 

selected IP address. 

 To Print: Click File > Print, and then select the information you want to print. 

#2 How to Find and Retrieve Frequently Used MIBs Using MIB Viewer 

The MIB Viewer tool queries the extensive MIB database to display any OID or Table. It provides a quicker 

method of retrieving frequently used MIBs. 

To view an OID or table: 

Look for MIB Viewer in Engineer’s Toolset and launch the tool to open a new window.  

Step 1: Type the hostname or IP address of the target device. MIB Viewer directly queries the device for 

supported MIBs. 

Step 2: Provide an SNMP community string. If you want to modify values, ensure you provide the read-

write community string. 
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Step 3: Provide an OID or table name or enter an entire MIB tree. The MIB Viewer tool analyzes your 

input and determines the best way to format the results. The MIB Viewer downloads each OID and MIB 

tree in the order you enter them. 

 

Note: OID values in blue are read-write and can be changed if you supplied a read-write community string. Click 

the value and type a new value, or use the list to select a value. 
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Step 4: If you want to view details about a selected OID, including the numerical OID and description, 

click View > Details. 

Step 5: Copy, Export, or Print the result.  

After retrieving MIB values, MIB Viewer allows you to transfer that information to other tools through 

exporting and copy and paste capabilities. You can either copy, export, or print discovered information. 

 To Export: Click File > Export and then select the type of export. 

 To Copy: Click Edit > Copy, and then specify whether you want to copy all to the clipboard or a 

selected IP address. 

 To Print: Click File > Print, and then select the information you want to print. 

#3 How to Browse and Query MIB Values Remotely via SNMP MIB Browser 

The most critical part of any MIB Browser is the number of standard and proprietary MIBs it supports. 

Without the correct MIBs, the data collected from a remote device is difficult to interpret and use. The 

common use for an MIB Browser is to find out what MIBs and OIDs are supported on a particular device. 

The SolarWinds MIB Browser allows an engineer to easily walk any MIB Tree and determine what MIBs a 

particular piece of hardware supports. This is important when determining which SNMP OIDs to collect 

statistics or to monitor. 

The SolarWinds MIB Browser automatically analyzes the results from each SNMP query and displays the 

information in a readable form. The query results windows are also customizable. Network 

administrators can select the type of information to be displayed for each SNMP query. OIDs, defining 

MIB, access (read-only, read-write, no-access), OID status (standard, deprecated, obsolete), raw value, 

cooked value, English description, and other properties can be displayed while querying a remote device. 

To browse the MIB tree for a specific device: 

Look for the SNMP MIB Browser in Engineer’s Toolset and launch the tool to open a new window.  

Step 1: Click Select a Device. 

Step 2: Select or type a hostname or IP address in the Device or IP address field. 
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Step 3: If the device supports SNMP version 1 or version 2, click Community string, and then type the 

appropriate community string. If you want to remotely update values discovered by the MIB Browser, 

ensure you specify a read-write community string. 

 

Step 4: If the device supports SNMP version 3, complete the following procedure: 

a. Select Manage Credentials from the list, or click Add to create a new credential set and save it in 

the shared credentials database. 
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b. If you are adding a new credential set, specify the appropriate information: 

o Credential set – the name that represents the credentials you specify on the Add Credentials 

window. This name displays in the SNMP Version 3 list in Toolset tools that support the 

shared credentials database. 

o Context – a named designation, similar to a group or domain name, to which the user name 

belongs. Context is mandatory if it has been defined for the object being managed. 

o User name – the name of the user with access to the device. 

o Authentication type – the authentication type you want to use when logging on to the device, 

for example, MD5. 

o Authentication password/key – the password or key that corresponds to the authentication 

selected. 
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o Encryption type – the encryption used when communicating with the device, for example, 

DES (56bit) or AES (128 or 256 bit) encryption. 

o Encryption password/key – the password or key that corresponds to the encryption selected. 

If you want to remotely update values discovered by the MIB Browser, ensure you specify credentials 

with read-write access. 

Step 5: For Browsing, select an OID from the MIB Tree on the left. 

Step 6: If you are not sure which OID to select, complete the following procedure to view a number of 

useful values: 

 

a. Expand iso > org > dod > internet > mgmt > mib-2. 

b. Click system. 

c. Click Get Walk/Tree to walk the system tree. Click the field and start typing, or use the drop-down 

menus within each field. 
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Note: You can right-click any SNMP value and select "Details..." from the popup menu to get more information 

about it. 

Step 7: Copy, Export or Print the result.  

After retrieving MIB values, MIB Walk allows you to transfer that information to other tools through 

exporting and copy and paste capabilities. You can either copy, export or print discovered information. 

 To Export: Click Export Table and then select the type of export. 

 To Copy: Right Click MIB Values to Copy, and then specify whether you want to copy all to the 

clipboard or a selected IP address. 

 To Print: Click Print, and then select the information you want to print. 

Top 5 Reasons to Try SolarWinds Engineer’s Toolset 

Engineer’s Toolset delivers an advanced collection of monitoring, discovery, diagnostic, and Cisco® tools. 

Here are the top 5 reasons to use SolarWinds Engineer’s Toolset: 

 All the network tools you need in one complete package. 

 Monitoring tools include Real-Time Interface Monitor, SNMP Real-Time Graph, and more. 

 Diagnostic tools include Ping Sweep, DNS Analyzer, and Trace Route, and more. 

 Network discovery tools include Port Scanner, Switch Port Mapper, Advanced Subnet Calculator, 

and more. 

 Cisco management tools include Real-time NetFlow Analyzer, Config Downloader, & more. 
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SolarWinds Engineer’s Toolset has more than 50 Network Tools that help you manage and perform your 

everyday network management related tasks at ease. It provides all the right tools to easily and 

effectively troubleshoot your network.  

              

About SolarWinds 

SolarWinds (NYSE: SWI) provides powerful and affordable IT management software to customers 

worldwide. Focused exclusively on IT Pros, we strive to eliminate the complexity in IT management 

software that many have been forced to accept from traditional enterprise software vendors. 

SolarWinds delivers on this commitment with unexpected simplicity through products that are easy to 

find, buy, use, and maintain, while providing the power to address any IT management problem on any 

scale. Our solutions are rooted in our deep connection to our user base, which interacts in our online 

community, thwack®, to solve problems, share technology and best practices, and directly participate in 

our product development process. Learn more at http://www.solarwinds.com. 
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